1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2005-508 Múltiples Buffer Overflows en Skype.

Se reportarón varias vulnerabilidades en Skype, que pueden explotarse para ocasionar una negación de servicio (DoS) o comprometer el sistema de un usuario.

  • Fecha de Liberación: 25-Oct-2005
  • Ultima Revisión: 8-Nov-2005
  • Fuente:

    Pentest Limited Security Advisory
    ptl-2005-01

  • CVE ID: CAN-2005-3265 CAN-2005-3267
  • Riesgo Altamente crítico
  • Problema de Vulnerabilidad Remoto
  • Tipo de Vulnerabilidad Buffer overflow

Sistemas Afectados

Skype 1.1.0.6(Pocket PC)
Skype 1.2.0.17(Linux)
Skype 1.3.0.16(Mac OS)
Skype 1.4.0.83(Windows)
  1. Descripción

    Se reportarón varias vulnerabilidades en Skype, que pueden explotarse por personas maliciosas para ocasionar una negación de servicio (DoS) o comprometer el sistema de un usuario.

    • Existe un error en el control del límite de la memoria al manejar URIs específicas de Skype por ejemplo "callto://" y "skype://". Esto puede explotarse para ocasionar un desbordamiento de memoria y permitir la ejecución de código arbitrario cuando el usuario ingresa dentro de una URL maliciosa.

    • Existe un error en el control del límite de la memoria al importar una VCARD. Esto puede explotarse para ocasionar un desbordamiento de memoria y permitir la ejecución de código arbitrario cuando el usuario importa una VCARD maliciosa.

    Las vulnerabilidades #1 y #2 fueron reportadas de la versión 1.1.0.0 a la 1.4.0.83 de Skype para Windows.

    • Existe un error en el control del límite de la memoria al manejar el tráfico de un cliente no específicado. Esto puede explotarse para ocasionar un desbordamiento de memoria en el segmento de heap.

      Una explotación exitosa tiraría al cliente de Skype.

    La vulnerabilidad fue reportada en las siguientes versiones:

    * Skype para Windows versión 1.4.0.83 y anteriores.
    * Skype para Mac OS X versión 1.3.0.16 y anteriores.
    * Skype para Linux versión 1.2.0.17 y anteriores.
    * Skype para Pocket PC versión 1.1.0.6 y anteriores.
    
  2. Impacto

    Negación de servicio (DoS).

    Acceso al sistema.

  3. Solución

    Actualizar a la versión corregida.
    http://www.skype.com/download/

    Skype para Windows:
    Actualizar a la versión 1.4.0.84 o posterior.

    Skype para Mac OS X:
    Actualizar a la versión 1.3.0.17 o posterior.

    Skype para Linux:
    Actualizar a la versión 1.2.0.18 o posterior.

    Skype para Pocket PC:
    No hay actualización disponible.

  4. Apéndices

    Mayor información.

    http://www.pentest.co.uk/documents/ptl-2005-01.html
    http://www.skype.com/security/skype-sb-2005-02.html
    http://www.skype.com/security/skype-sb-2005-03.html

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Floriberto López Velázquez (flopez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT