1 2 3 4 5 6

Vulnerabilidades rss pdf

Coordinación de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2006-019 Debian liberó una actualización para libapache2_mod_auth_pgsql.

Debian liberó una actualización para libapache2_mod_auth_pgsql. Esta repara una vulnerabilidad que puede explotarse para comprometer un sistema vulnerable.

  • Fecha de Liberación: 11-Ene-2006
  • Ultima Revisión: 11-Ene-2006
  • Fuente:

    Debian Security Advisory
    DSA-935-1 libapache2-mod-auth-pgsql

  • CVE ID: CAN-2005-3656
  • Riesgo Altamente crítico
  • Problema de Vulnerabilidad Remoto
  • Tipo de Vulnerabilidad Formato de cadena

Sistemas Afectados

Debian GNU/Linux 3.1 alias sarge mod_auth_pgsql 2.0.2b1-5sarge0
  1. Descripción

    Debian liberó una actualización para libapache2_mod_auth_pgsql. Esta repara una vulnerabilidad que puede explotarse por personas maliciosas para comprometer un sistema vulnerable.

      Se encontraron varios errores de formato de cadena en la forma que mod_auth_pgsql registra la información. Es posible que un atacante remoto ejecute código arbitrario como el usuario "apache" si el módulo es utilizado para autenticar a los usuarios.

      Ver:
      Vulnerabilidad de formato de cadena en el módulo mod_auth_pgsql de Apache
      http://www.seguridad.unam.mx/vulnerabilidadesDB/?vulne=4981

  2. Impacto

    Acceso al sistema.

  3. Solución

    Aplicar los paquetes actualizados.

    -- Debian GNU/Linux 3.1 (sarge) --

    Código Fuente:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0.dsc
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0.diff.gz
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1.orig.tar.gz

    Alpha:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_alpha.deb

    AMD64:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_amd64.deb

    ARM:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_arm.deb

    Intel IA-32:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_i386.deb

    Intel IA-64:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_ia64.deb

    HPPA:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_hppa.deb

    Motorola 680x0:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_m68k.deb

    Big endian MIPS:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_mips.deb

    Little endian MIPS:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_mipsel.deb

    PowerPC:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_powerpc.deb

    IBM S/390:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_s390.deb

    Sun Sparc:
    http://security.debian.org/pool/updates/main/liba/libapache2-mod-auth-pgsql/libapache2-mod-auth-pgsql_2.0.2b1-5sarge0_sparc.deb

  4. Apéndices

    http://www.debian.org/security/2006/dsa-935
    http://www.seguridad.unam.mx/vulnerabilidadesDB/?vulne=4981

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Floriberto López Velázquez (flopez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Coordinación de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México Aviso legal |  Créditos |  Staff |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT