Coordinación de Seguridad de la Información

Coordinación de Seguridad de la Información

Información y servicios de seguridad en cómputo

1 2 3 4 5 6 7 8

Vulnerabilidades rss pdf

Subdirección de Seguridad de la Información - UNAM-CERT -- DGTIC-UNAM

Vulnerabilidad de Seguridad UNAM-CERT-2008-001 Liberación de actualizaciones de seguridad acumulativas en PostgreSQL

El grupo de desarrollo de PostgreSQL ha liberado las últimas actualizaciones, las cuales corrigen cinco vulnerabilidades de seguridad. Estas vulnerabilidades son consideradas críticas y los administradores de base de datos que usen PostgreSQL deberian instalar las actualizaciones tan pronto como sea posible.

  • Fecha de Liberación: 6-Ene-2008
  • Ultima Revisión: 29-Ene-2008
  • Fuente: PostgreSQL News
  • Riesgo Alto
  • Problema de Vulnerabilidad Local y remoto
  • Tipo de Vulnerabilidad Múltiples vulnerabilidades

Sistemas Afectados

Unix-like systems PostgreSQL == 7.3
Unix-like systems PostgreSQL == 7.4
Unix-like systems PostgreSQL == 8.0
Unix-like systems PostgreSQL == 8.1
Unix-like systems PostgreSQL == 8.2
  1. Descripción

    I. Elevación de privilegios en los índices de las funciones

    Como una característica única, PostgreSQL permite a los usuarios crear índices sobre los resultados de las funciones definidas por el usuario, conocidas como "índices de expresiones". Esto provee dos vulnerabilidades de elevación de privilegios:

    1. Los índices de funciones eran ejecutadas como el superusuario y no como el dueño de la tabla durante VACUUM y ANALYZE.

    2. SET ROLE y SET SESSION AUTHORIZATION eran permitidas dentro del los índices de las funciones.

    II. Negación de servicio con expresiones regulares.

    Tres cuestiones diferentes en las bibliotecas de expresiones regulares usadas por PostgreSQL permitían a un usuario malicioso iniciar una negación de servicio pasando determinadas expresiones regulares en las consultas SQL. Primero los usuarios podían crear ciclos infinitos usando algunas expresiones regulares especificas. Segundo, determinadas expresiones regulares complejas pueden consumir una cantidad excesiva de memoria. Tercero, una referencia fuera de rango a números podía ser utilizado para tirar el backend.

    III. Elevación de privilegios con DBLink

    Las funciones DBLink combinas con "local trust" o "ident authentication" podían ser usadas por un usuario malicioso para obtener privilegios del superusuario. Esta vulnerabilidad ha sido arreglada y no afecta a usuarios que no tengan instalado DBLink (modulo opcional) o que estén usando un password de autenticación para el acceso local.

  2. Impacto

    Aunque no se tiene conocimiento de que estas vulnerabilidades hayan sido explotadas por usuarios maliciosos, una explotación exitosa de estas vulnerabilidades puede llevar a una negación de servicio o la elevación de privilegios.

  3. Solución

    Instalar las últimas actualizaciones.

  4. Referencias

    http://www.postgresql.org/about/news.905

    CVE-2007-6600

    CVE-2007-4769

    CVE-2007-4772

    CVE-2007-6067

    CVE-2007-6601

La Subdirección de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

  • Vicente Hernández Jiménez (bec_vhernandez at correo dot seguridad dot unam dot mx)
  • Alejandro Nuñez Sandoval (anunez at seguridad dot unam dot mx)

UNAM-CERT
Equipo de Respuesta a Incidentes UNAM
Subdirección de Seguridad de la Información

incidentes at seguridad.unam.mx
phishing at seguridad.unam.mx
http://www.cert.org.mx
http://www.seguridad.unam.mx
ftp://ftp.seguridad.unam.mx
Tel: 56 22 81 69
Fax: 56 22 80 47


Universidad Nacional Autonoma de México 100 años UNAM EQA ISO 27001 FIRST LOGO Aviso legal |  Créditos |  Staff |  Acerca |  Contacto |  FTP |  Administración
Copyright © Todos los derechos reservados
UNAM - CERT