Vulnerabilidad de Seguridad UNAM-CERT-2017-001 Ejecución remota de código en Apache Struts

Un elemento de Apache Struts permite la ejecución remota de código de manera arbitraria.

Fecha de liberación: 
10/03/2017
Última revisión: 
10/03/2017
Fuente: 
Nike Zheng DBAPPSecurity
Riesgo: 
Alto
Problema de vulnerabilidad: 
Remoto
Tipo de vulnerabilidad: 
Ejecución remota de código
Sistemas afectados: 

Apache Struts

Descripción: 

Esta vulnerabilidad (CVE-2017-5638) es un bug que afecta al Multipart parser de Jakarta y permite la ejecución remota de código.

Los atacantes estan aprovechando esta vulnerabilidad para infectar los equipos y distribuir malware.

Impacto: 

Un atacante podría aprovechar la vulnerabilidad para tomar control del servidor.

Solución: 

Actualizar a Apache Struts 2.3.32 o 2.5.10.1

Se recomienda a los usuarios de Apache Struts que utilicen el complemento Multipart parser, basado en Jakarta, actualizar lo antes posible a la versión 2.3.32 o 2.5.10.1

Referencias: 

https://cwiki.apache.org/confluence/display/WW/S2-045

http://www.seguridad.unam.mx/noticia/?noti=3206

http://blog.talosintelligence.com/2017/03/apache-0-day-exploited.html

La Coordinación de Seguridad de la Información/UNAM-CERT agradece el apoyo en la elaboración ó traducción y revisión de éste Documento a:

UNAM-CERT

Ejecución remota de código en Apache Struts